start_topic

Startseite

Mit dieser Seite wird die Hilfe eröffnet.

Willkommen zur Demo-Hilfe!

Dieses Onlinehilfe-Projekt wurde mittels DITA-Topics und XSLT 2.0 sowie dem MS-Help-Compiler (hhc.exe) umgesetzt.

XML-Schule Merseburg Zur Website des Autors ...


topic1

Erster Hauptpunkt

Hier folgen die Inhalte für den ersten Hauptpunkt.

Überschrift ...

Absatz 1 ...

Absatz 2 ...

Nun folgt eine ungeordnete Liste:

  • Text
  • Text
  • Text


topic11

Unterpunkt 1.1

Hier folgen die Inhalte für den Unterpunkt 1.1.

Eine Tabelle

DITA unterstützt das CALS-Tabellenmodell.

Spalte 1 | Spalte 2 | Spalte 3
Zelle 1.1 | Zelle 1.2 | Zelle 1.3
Zelle 2.1 | Zelle 2.2 | Zelle 2.3


topic12

Unterpunkt 1.2

Hier folgen die Inhalte für den Unterpunkt 1.2.

Überschrift ...

Hier wird noch fleißig gearbeitet.


topic2

Zweiter Hauptpunkt

Hier folgen die Inhalte für den zweiten Hauptpunkt.

Überschrift ...

Eine geordnete Liste:

  1. Text
  2. Text
  3. Text


topic21

Unterpunkt 2.1

Hier folgen die Inhalte für den Unterpunkt 2.1.

Überschrift ...

Hier wird noch fleißig gearbeitet.


topic22

Unterpunkt 2.2

Hier folgen die Inhalte für den Unterpunkt 2.2.

Überschrift ...

Hier wird noch fleißig gearbeitet.


dita_task

Kommandozeilen-Helpcompiler verwenden

Es wird die Benutzung von hhc.exe erläutert.

  1. Öffnen Sie das Konsolenfenster über Start > Ausführen > cmd > OK!
    (Das Fenster ist für Eingaben bereit.)
  2. Wechseln Sie in das gewünschte Verzeichnis mit dem cd-Kommando!
    (Die Eingabeaufforderung wird neu positioniert.)
  3. Rufen Sie den Helpcompiler auf: hhc dateiname.hhp
    (Der Helpcompiler arbeitet und erzeugt eine CHM-Datei oder gibt Fehlermeldungen bzw. Hinweise aus.)

Die fertige CHM-Datei kann nun angezeigt werden.


zusatz_a

Kein DITA-Topic-File vorhanden

Platzhalter-HTML-Dokument wurde verwendet.


zusatz_b

Kein DITA-Topic-File vorhanden

Platzhalter-HTML-Dokument wurde verwendet.


schluss_topic

Zusammenfassung

Mit dieser Seite wird die Hilfestruktur abgeschlossen.

Fazit

Die Darwin Information Typing Architecture (DITA) eröffnet neue Möglichkeiten für das Single-Source-Publishing.